ぺんぎん戦記
   Linux&VMware&Solaris活動日記。でもメイン使用はMacOSX。
  >> ホーム
  >> RSS1.0
カテゴリー

 

VMwareでお役立ち

第3版は5.1に対応。

Hyper-Vの教科書でた

スマートフォンに欠かせない

Windowsも勉強しよう

最近のトラックバック

リンクいろいろ




お気に入り

このブログをリンクに追加する

プロフィール

  • Author:じょにーパン
  • lsをslとよく間違えちゃう。

スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

スポンサー広告 | 固定リンク | このエントリーを含むはてなブックマーク |はてなブックマーク - スポンサーサイト
サーバー構築・運用ブログランキングへ →人気ブログランキングへ
(--/--/--(--) --:--)

Firefox7.0 on MacOSX(snow leopard) で Echofon for Twitter 1.9.7.3 を使う
Echofon for TwitterはFirefoxで使えるtwitterアドオンですが
2.xになってからそれまでのバージョンとユーザーインターフェイスが
大きく変わり、かつ、最新のFirefoxで動作しなくなってしまったことから
個人的に使いにくくどうしようかと思っていたら、
同じように考えてる有志のかたがFirefox 5.x以降でも使える
Echofon for Twitter 1.9.7.3 を公開されていて、
それはそれは大変ありがたく助かっておりました。

詳しくはここ
https://addons.mozilla.org/ja/firefox/addon/echofon-for-twitter/reviews/user:1410733

んでFirefox5以降でも動くEchofon 1.9.7.3はここ
http://antwan.fr/xpi



ところが、Firefox7.0にしたらどうにも私の環境では
動かなくなってしましまいました。ちなみに使用OSは
MacOSX10.6.8です。


なので中身をちょっと確認してみることにしました。




さて、上記にあります
echofon_for_twitter-1.9.7.3.3-fx7.xpiをダウンロードしてきて
Firefox7.0にインストールしても、インストールはできるのですが、

Cc['@naan.net/twitterfox-sign;1'] is undefined

とか

Echofon does not support this platform or custom build Firefox. (Can't get OAuth signer.) / (Fx version 7.0 / ABI x86_64-gcc3)

とか、エラーのポップアップがでてアドオンは正しく動いてくれません。

なにかわかるかなーと駄目もとで
echofon_for_twitter-1.9.7.3.3-fx7.xpiの拡張子を
.zipに変更して、解凍してみて、chrome.manifest を
エディタで開いて覗いてみました。


すると、気になる箇所がありました。
 :
# Firefox 7
 :
binary-component platform/Darwin/7/libechofon.dylib ABI=Darwin_x86_64-gcc3 appversion>=7.0a2
binary-component platform/Darwin/7/libechofon.dylib ABI=Darwin_x86-gcc3 appversion>=7.0a2
 :
 :

ここかな?

解凍されるフォルダの
platform/Darwin/7/にあるものを確認したら
libechofon.dylib
libechofon-x86_64.dylib
と2つあります。
きっとx86_64とx86で分けてあるっぽい、と予想して

binary-component platform/Darwin/7/libechofon-x86_64.dylib ABI=Darwin_x86_64-gcc3 appversion>=7.0a2

に書き換えて保存。
(ついでにFirefox8のところも同じように変更)

解凍されたファイルを再度1つのzipにまとめて
(MacOSXの機能で操作するなら、解凍されたものを
 複数全部(今回は8個)を選択して「8項目を圧縮」とする)
拡張子を.xpiに変更してアドオンのファイルを作り直し。

Firefox7.0にインストールしたら無事に動いてくれました。
よかったよかった。

Darwinのところだけ記述がまちがってるっぽいので
他のOSで使う場合は、元ファイルを変更しなくても
問題なく動くかもしれません。



関連記事

テーマ:ウェブブラウザ - ジャンル:コンピュータ

Mac | 固定リンク | トラックバック:0 | レス:1| このエントリーを含むはてなブックマーク |はてなブックマーク - Firefox7.0 on MacOSX(snow leopard) で Echofon for Twitter 1.9.7.3 を使う
サーバー構築・運用ブログランキングへ →人気ブログランキングへ
(2011/09/28(水) 20:30)

<<WiMAX導入しました | ホーム | VCP教科書 VMware vSphere 4>>

コメント
  firefox9だと
うまくいかないですね。困った
URL | 本人 #- | 2012/01/06(金) 13:28 [ 編集 ]

コメントの投稿
記事に無関係なアダルトサイトの紹介などはご遠慮ください。
削除させていいただく場合があります。

管理者にだけ表示を許可する

トラックバック
トラックバックURLはこちら
http://spacesheriffsharivan.blog9.fc2.com/tb.php/127-5b628a26
この記事にトラックバックする(FC2ブログユーザー)

copyright © 2005 ぺんぎん戦記 all rights reserved.
Powered by FC2ブログ. / PHPウェブログシステム3 / ネットマニア


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。